Raspberry Pi: LED an Kameramodul deaktivieren

Möchte man das die rote LED des Kameramoduls während der Aufnahme nicht leuchtet, kann man diese unter /boot/config.txt deaktivieren. Dazu geht ihr wie folgt vor:

config.txt zum bearbeiten öffnen:

Folgenden Eintrag in hinzufügen/ändern:

System neustarten, damit die Änderung übernommen wird:

 

 

#RaspberryPi – Probleme mit Speicherkarten

Da mein #Raspi sehr unvorbereitet bei mir ankam 🙂 hatte ich mich noch nicht wirklich um eine SD-Karte gekümmert. Da er plötzlich bei mir zu hause war, suchte ich und fand ein Paar Karte in meiner Schublade.

Ich lud mir das aktuelle ArchLinux Image von raspberrypi.org und spielte es auf eine der vielen SD-Karten. In meinem Fall handelte es sich um eine SanDisk 4GB Class 2 (zu spät gemerkt ;). Ich legte sie in den #Raspi und startete ihn. Alles verlief problemlos – Arch bootete. Als nächstes startete ich mit „sudo pacman -Syyu“ ein komplettes Systemupdate. Auch dies verlief ohne Probleme. Nach dem Update folgte ein Neustart und nun =>; „Kernel panic“

Oh man….Also Debian Image runtergeladen und Image wieder auf die gleiche SD-Karte gespielt und in den #Raspi eingelegt. Nun beim booten „MMC0“ Fehler 🙁

Kann doch alles nicht sein habe ich mir gedacht und eine andere Karte genommen, Debian drauf, gebootet und keine Probleme. Tja, das dachte ich auch nur bis zum nächsten Neustart 😀 Nun leuchtete nur ein rote LED und nichts tat sich. Erst nach mehrmaligen Strom raus und wieder rein tat sich etwas.

Meine Güte ist denn der #Raspi defekt ?

Nun reichte es mir und ich machte mich in den Weiten des Internets auf die Suche nach einer Lösung. Fündig wurde ich bei elinux.org und einer dort gezeigten Kompatibilitäts-Liste für SD-Karten und weiterer Hardware und im raspberrypi.org Forum in dem die gleichen Probleme auftauchten. Diese Fehler seien auf eine nicht kompatible SD-Karte zurückzuführen.

Ab in den MediaMark mit der o.g. Liste auf dem iPhone im Gepäck und eine passende SD-Karte rausgesucht. Habe mich vor Ort für eine SanDisk 4GB Class 4 Karte entschieden. Zuhause angekommen habe ich direkt wieder das Debian Image draufgespielt und getestet. Siehe da, alles läuft nun wunderbar 🙂

Am Wochenende habe ich mir nochmal ein Doppelpack 4GB Class 4 SD-Karten von Kingston bei Amazon für schlappe 8,45€ bestellt. Diese sollten heute eintreffen und wenn diese ebenso funktionieren werde ich es hier berichten 😉

UPDATE:
Die SD Karten (Kingston SD4/4GB) funktionieren bei mir nicht mit Debian (vom 19.04.2012). Werde es morgen nochmal versuchen 🙁 MMC0 ERROR).

ArchLinux hingegen läuft mit dem Image vom 29.04.2012 bis jetzt super auf den Kingston Karten. 🙂

UPDATE 29.05.2012:
Möglich Ursachen für einen Kernel panic könnte ebenfalls ein zu klein dimensioniertes Netzteil sein. Es sollte 5V und 1A liefern. Alles drunter könnte Probleme bereiten (gerade wenn weitere USB-Geräte angeschlossen sind. Ich persönlich habe ein Logitech USB-Hub mit eigener Stromversorgung für meine weiteren Geräte an meinem RaspberryPi angeschlossen.
Ebenfalls könnte ein angestecktes USB-Gerät für Probleme sorgen. Wenn möglich, versucht mal ohne zusätzliche Hardware zu booten oder testet es mal mit z.B. einer anderen Tastatur.